Lightbox Gallery pluginのアップデート

うちのWordPressではLightbox Gallery pluginを使っています。NextGen Galleryも併用しているのですが、シンプルに見せたいときはこちらを使うことが多いかな。

んで、そのLightbox Gallery pluginが0.3から0.4にアップデートされていたので、即座に自動アップデートをかけてみたのですが…。

あり?

NEXTとかPREVとかCLOSEの画像が表示されなくなっちった。これじゃ、大きな画像にしたあとどうすりゃいいのかわからん。

なんでだろー、と悩んで作者の方のページを穴のあくほど見つめてみた。そしたら、設定をしなきゃいけないんだった、と。lighbox-gallery.jsの中にあるURLを書き直さないとちゃんと画像を表示しないことを再度認知しました。うちの場合には、以下の赤いところを追記しないといけない。

var lightbox_path = 'http://'+location.hostname+'/wp/wp-content/plugins/lightbox-gallery/';

つまり、自動アップデートかけたままぢゃいけないんですねーw

というわけで、自動アップデートかけて、そのままにしちゃだめです。lighbox-gallery.jsをちゃんと書き直しましょう。初めてインストールするときには気をつけるんだけど、アップデートのときにはほぼすべてのプラグインがそのまま動くので気付きにくいところです。

※追記

Lightbox Gallery Pluginがアップデートされて、テーマファイルにこの.jsファイルを入れておけばそちらが有効になるように変更されています。そのため、自動アップデートでも安心!.jsファイルを入れ替えないといけないときはちょっと手間ですが、今のところだいじょうぶ。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です